AccueilAccueil  MumbleMumble  WIPs Team PP  RechercherRechercher  MembresMembres  S'enregistrerS'enregistrer  ConnexionConnexion  Liens  




Partagez | 
 

 [WIP 75%] Pincab nnanard8

Voir le sujet précédent Voir le sujet suivant Aller en bas 
Aller à la page : Précédent  1, 2, 3  Suivant
AuteurMessage
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 15:40

Bon les amis, je viens de racheter deux barres de 8 relais car je pensait que les relais étaient défectueux...

Cela fait malheureusement pareil avec les nouveaux composants, le soucis ne viens donc pas des relais...( en plus maintenant je me retrouve avec des barres de relais en plus )

J'ai essayé de changer la KL25Z de port usb cela ne change rien,

En fait c'est comme si quand la carte relais est branchée en 5v il y a assez de jus pour allumer les diodes mais pas à fermer les relais.
Quand je branche la carte en 12v et que je teste les pins avec une masse ça ferme les relais ok mais dès que je branche un port de la kl25z c'est comme si il me détectais tout le temps une masse, que le port soit ouvert ou fermé et piloté par la masse ou non.

Sinon j'ai a dispo une carte Leonardo clonée en ledwiz, j'ai essayé de brancher un port sur un des ports de la carte relais ça fait pareil, testé avec ledblinky ca fait pareil (du coup ce sont déjà logiquement des ports pilotés par la masse sur une telle carte ?)

Je suis un peu désespéré, je ne vois pas du tout d'où le souci peut venir Crying or Very sad Crying or Very sad , un électronicien pour m'aider ?
Revenir en haut Aller en bas
xav71

avatar

Messages : 219
Département : 69

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 16:13

Hello,
peut-être un problème de masse commune qui manque (en entrée des cartes relais) ?
La diode de contrôle de la kl25Z clignote bien toujours entre vert et bleu. Pas de déconnexion (diode rouge/orange) ? Pas de son windows qui indique que ta carte se déconnecte ?
Ta carte mère est ancienne ?
Revenir en haut Aller en bas
Aetios

avatar

Messages : 970
Département : 50

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 16:29

@Nnanard8 : comme le dit @xav71, ça ressemble à un problème de masse commune. tu es sur d'avoir connecté toutes tes masses entre elle.
Quand je dis toute, je veux dire TOUTE, c'est dire les masses de 5V, 12V, 24V, elles doivent toutes être reliées entre elles.

Il n'y a pas de raison que ça ne fonctionne pas comme ça, surtout si tes relais s'activent.

Fais un schéma de ton câblage même vite fait à la main qu'on puisse le vérifier parce que là c'est difficile de t'aider. Le fait de savoir qu'une LED s'allume c’est bien mais ça nous parle pas en fait  .

Donc commence par nous montrer ton câblage et après on va décomposer le problème pas à pas.

Pour ma part, je ne suis pas sûr que ce soit un problème de KL25Z, tu n'aurais de commande visible sur les leds des relais si c'était le cas.
Revenir en haut Aller en bas
https://www.facebook.com/TheFrenchclanclan/
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 17:08

Alors place aux schémas :

Test carte relais en 5v : carte reliée en 5v à l'alim avec test des pins à la masse
--> quand contact des pins à la masse les diodes s'allument mais les relais ne se ferment pas



Test carte relais en 12v : carte reliée en 12v à l'alim avec test des pins à la masse
--> quand contact des pins à la masse les diodes s'allument et les relais se ferment



Branchement en 5v à la kl25z : les diodes réagissent au dof et à ledblinky (configurés avec pinscape pour envoyer une masse) mais les relais ne se ferment pas



Sinon pas de souci de déconnexion de la kl25z, la diode clignote vert et bleu.

Branchement en 5v à l'alim : les diodes réagissent au dof et à ledblinky (configurés avec pinscape pour envoyer une masse) mais les relais ne se ferment pas



Branchement en 12v à l'alim et pins à la kl25z : les relais se ferment et ne s'ouvrent plus diodes restent allumées, un léger clignotement des diodes si solicitation à led blinky mais relais restent fermés. Si déconnection d'un pin a la kl25z le relais s'ouvre et la diode s'éteint mais dès rebranchement la diode s'allume et le relais se ferme (que le port soit activé ou non dans pinscape controller ou led blinky)



Voili voilu, pour la masse commune, tout est relié à une multiprise qui est reliée à la terre.
Revenir en haut Aller en bas
Aetios

avatar

Messages : 970
Département : 50

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 17:14

désolé @Nnanard8 mais de ce que j'en vois la masse de ta KL25Z n'est pas relié à la masse commune (sur ton alim PC). C'est IM.PE.RA.TIF !!!
Tu confonds prise de terre et masse commune, ça n'a rien à voir en courant continu.

Par ailleurs, tes relais ont besoin de 12V pour fonctionner donc je comprends pas trop tes essais avec du 5V et alimenter depuis la KL25Z ???

Bref, commence par relier la masse de ta KL25Z à la masse de ton alim PC (tu en as plusieurs de dispo sur le petit module de branchement). ça devrait être mieux


Dernière édition par Aetios le Mer 31 Mai 2017 - 17:16, édité 1 fois
Revenir en haut Aller en bas
https://www.facebook.com/TheFrenchclanclan/
xav71

avatar

Messages : 219
Département : 69

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 17:15

Il semble donc que ta carte relais actionne en 12V.
Il faut donc utiliser une alimentation externe, car le port USB de la KL est en 5V.
Les masses de la terre ne sont pas les masses des cartes. De mes souvenirs de techno, une tension est une DIFFERENCE de potentiel, il faut donc deux points (le 5V et la masse par exemple). D'ou l'importance quand on veut piloter avec une tension, 12V par exemple, d'avoir la masse commune.
Relie la masse de la KL à la masse (fil noire) de ton alim.

@Aetios a été plus rapide que moi
voilà un schéma que je vais utiliser, fait par @lololol
Les masses sont reliées entre elles (masse 5V interne et externe).
[Mode Prof ON !]
Sans référence commune niveau tension, le relais ne pourra s'activer, ou alors de manière aléatoire.
Pour faire simple, une tension en elle même ne veut rien dire. C'est comme une altitude. Le Mont Blanc est haut de 4810m. Seul, ça ne veut rien dire. La référence est le niveau de la mer, la différence d'altitude du Mont Blanc est de 4810m par rapport au niveau de la mer. Si par exemple on veut comparer avec la hauteur du Mont Olympe sur Mars, il faut une référence commune. On fixe cette référence, et on peut donner l'altitude du Mont Olympe (21229m). En alignant le niveau de la mer de la terre et celui de référence de MArs, on peut dès lors comparer, 4810 par rapport à 21229.
En électricité, c'est pareil. Pour le tensions, si on veut que ça marche, il faut des masses communes car une tension est en fait une différence (de potentiel donc de charge). Et c'est cette différence qui génère le courant, comme une différence de hauteur génère un cours d'eau qui s'écoule du plus haut vers le plus bas...

Désolé pour cette pseudo-leçon 
[Mode Prof OFF]


Revenir en haut Aller en bas
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 20:39

Merci pour vos infos les amis j'ai fait comme vous dites avec la masse de la kl25z reliée a la masse de l'alim, ca ne fonctionne toujours pas.
Led restent allumées avec relais fermés. Evil or Very Mad 


est ce que ça vaut le coup de toucher à la zone avec les jumpers comme sur le schéma ci dessus ?
Revenir en haut Aller en bas
xav71

avatar

Messages : 219
Département : 69

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 20:49

Il me semble que tu dois relier le 12v qqpart sur la carte kl.
La kl ne sort que du 5v.
Je suppose donc que tu dois mettre du 12V qqs part sur la kl.
Il doit y avoir une entrée pour ça je pense ?


Dernière édition par xav71 le Mer 31 Mai 2017 - 21:18, édité 1 fois
Revenir en haut Aller en bas
Stef26



Messages : 38
Département : 26

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 21:12

Essaye de voir ici :

http://www.pincabpassion.net/t2594p555-termine-pincab-de-shadow


tu y trouveras le plan de @shadow_shd



Sinon tu as ces cartes que je préfères aux relais
Revenir en haut Aller en bas
mariopourlavie
Modérateur
avatar

Messages : 1582
Département : 38

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 21:25

@Nnanard8 a écrit:
Alors place aux schémas :

Test carte relais en 5v : carte reliée en 5v à l'alim avec test des pins à la masse
--> quand contact des pins à la masse les diodes s'allument mais les relais ne se ferment pas





Avec ce schéma ultra simple, il n'y a aucune raison pour que tes relais ne claquent pas , donc tu as , pour moi, forcément un problème d'alim qui ne te donne pas 5v ? Ou alors tes relais sont en commandes positives ? 

As tu vérifier tes 5v ?

Peux tu nous mettre une photos de "TA" carte relais 5v s'il te plaît  ?

 On va trouvé avec tout ce monde sur le coup 
Revenir en haut Aller en bas
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Mer 31 Mai 2017 - 22:33

Alors voici les photos des barres de relais, elles viennent de ebay c'est le modèle qui est indiqué sur le forum.





J'ai fait un test des sorties de l'alim avec mon réhausseur de tension (pour avoir du 24v pour les contacteurs) car il a un affichage de tension d'entrée et bien les sorties 5v sont bien à 5v et les sortie 12v sont bien à 12v

J'ai fait un test sinon en reliant la carte relais à la sortie du réhausseur puis en faisant augmenter la tension petit à petit. Avec les pins reliés à la KL25Z en mode sorties off (donc logiquement pas de relais à enclencher) et bien vers 6.10 volts les relais s'enclenchent tout seul. si je retire les pins les relais s'ouvrent et les diodes s'éteignent. Tout cela avec la masse de le kl25z reliée à la masse de l'alim.



Hyper bizzare confused confused
Revenir en haut Aller en bas
peskopat
Admin
avatar

Messages : 5930
Département : 54

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 9:29

J'avais eu le même problème avec ces cartes , j'ai mis ceux là du coup , plutot que de m'emmerder à trouver le problème , sinon prends des cartes mosfets .


Revenir en haut Aller en bas
https://www.youtube.com/channel/UCYIgslcMXdZ194XWO8JEfjQ
Aetios

avatar

Messages : 970
Département : 50

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 11:07

@Peskopat : lol! lol! lol!  comment tu nous tues là-dessus. On va quand même essayer de comprendre avant de lui dire de racheter des relais ou des cartes MOSFET    rire  rire  rire

@Nnanard8 : alors si je comprends bien tes essais, tu as réussi à avoir un enclenchement de ton relais avec une tension de 6V ? c'est bien ça ? C'est assez bizarre, tu as testé tes 4 cartes relais, sinon ? elles ont toutes le même symptôme.

Sur le nombre de membres présents sur ce fofo, je suis étonné de pas voir plus de monde à avoir eu ce souci sachant que c'est la solution la plus communément employée avec les KL25Z non ?

@mariopourlavie : quel type de relais as-tu utilisé toi ? pour rappel, ses cartes relais sont des cartes 12V

EDIT

@Nnanard8 : Il se pourrait que tes cartes soit en commande positive, as-tu modifié ton firmware dans Pinscape Tools pour faire l'essai depuis que tu as alimenté tes relais avec du 12V ?
Revenir en haut Aller en bas
https://www.facebook.com/TheFrenchclanclan/
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 13:21

@Aetios : OUI J'ai essayé les deux possibilités commande par la masse et par 3.3v

D'ailleurs j'ai fait un test à ce sujet :
- alimentation de la carte en 12v (12v sur vcc et gnd sur gnd)

et j'ai touché les pins avec un fil en 3.3v issu de mon alim, et bien le relais se ferme et la diode s'allume comme quand je teste à la masse !
J'ai testé avec du 5v pareil.
Si j'ai bien compris si tout se passait bien la kl25z devrait délivrer tout le temps 3.3v au relais et au moment ou elle donne une masse sur le pin : clac relais enclenché (dans le cas ou les sorties sont configurées pour se déclencher sous forme de masse) La carte devrait seulement réagir quand une masse est appliquée aux pins.

Je commence à me dire que mon prob viens du fait que j'ai des relais a alimenter en 12v et non en 5v, vous avez quoi comme type de relais vous autres ?

@peskopat : tu les a pris en 5v tes relais ?
Revenir en haut Aller en bas
xav71

avatar

Messages : 219
Département : 69

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 13:30

Moi j'ai des relais 5V, donc l'état haut est bien celui de la carte. Et la masse pour l'état bas qui actionne le relais.
C'est sur que si la carte KL n'envoie que du 0 ou 5V pour commander le relais, tu risques d'être toujours dans l'état bas, donc relais fermé.
Dans ce cas, il faudrait voir si la carte KL peut recevoir du 12V et piloter avec du 12V ?
A voir dans les pincab des membres si certains ont des relais activés en 12V.
As tu essayé d'enlever le cavalier sur la carte relais ? Ce cavalier semble mettre au même potentiel la tension d'alim externe du relais de la tension de commande ?
Revenir en haut Aller en bas
Aetios

avatar

Messages : 970
Département : 50

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 14:23

@Nnanard8 a écrit:
et j'ai touché les pins avec un fil en 3.3v issu de mon alim, et bien le relais se ferme et la diode s'allume comme quand je teste à la masse ! J'ai testé avec du 5v pareil.

Bon je pense que tu touches au but Wink

concrètement il faudrait que tu vérifies avec un multimètre quelle tension t'envoie la KL25Z lorsque que tu lui demandes d'activer un port LEDWIZ (à mon avis du 3.3V) entre le PIN concerné et la masse. ça permettrait de vérifier comment est géré la commande par le "+" et par la masse. ensuite tu connectes le PIN de KL25Z sur un PIN du relais et tu vérifies qu'il se ferme.

Allez courage ! tu y es presque Wink
Revenir en haut Aller en bas
https://www.facebook.com/TheFrenchclanclan/
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 16:33

Le problème c'est que quand la barre est alimentée en 12v :
- masse au pin : led allumé relais fermé
- 3.3v au pin : led allumé relais fermé
- 5 v au pin : led allumé relais fermé

Le relais se ferme quoi que je mette (a part mon doigt...) donc dès que je branche à la kl25z le relais se ferme et ne s'ouvre plus que je sois piloté par la masse ou par du 3.3v

Revenir en haut Aller en bas
xav71

avatar

Messages : 219
Département : 69

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 19:01

J'ai du mal à comprendre. Si la carte relais est estampillée 12VDC, c'est qu'un des deux niveaux demande une tension proche de 12V et l'autre le niveau 0V (la masse). Il faut donc bien envoyer une tension 12V à un moment donné. Si la carte KL n'est qu'alimentée en 5v, comment peut-elle sortie du 12V ? Il faut bien amener du 12V quelques part ? C'est donc logique qu'entre 0 et 5V on reste dans le même état. Je dis une connerie ou pas ?
Revenir en haut Aller en bas
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 19:16

Non ce n'est pas tout a fait ça, si la carte est estampillée 12v c'est qu'il faut l'alimenter en 12v pour qu'elle fonctionne.

Ensuite elle reçoit des informations de la part de la kl25z par les pins, information qui va lui servir a ouvrir ou fermer les relais.

L'information est de deux nature : une masse ou bien une tension (3.3v pour la kl25z) en fonction modèle de la carte les relais s'ouvrent ou se ferment. Certaines cartes sont pilotées par la masse c'est à dire que si une masse est appliquée a un pin le relai se ferme. D'autre cartes sont pilotées par une tension, si une tension est appliquée au pin le relai se ferme.

C'est un peu comme une voiture télécommandée les 12v ou les 5v ce sont les piles dans la voiture, le signal masse ou tension ce sont comme les infos qui viennent de la télécommande.

Dans mon cas le souci c'est que alimentée en 12v les relais se ferment en cas de signal masse ET tension (donc tout le temps fermés)

Il me semble qu'une kl25z ne pourra jamais délivrer du 12v seulement du 3.3v, et amener du 12v dans la carte et c'est barbecue assuré
Revenir en haut Aller en bas
xav71

avatar

Messages : 219
Département : 69

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 19:23

Merci pour ces précisions.
Donc dans ce cas là, le relais sera toujours fermé (0V ou 3,3V ou même 5V). A part réhausser la tension en sortie de la KL, je ne vois pas comment ça peut marcher alors. Pourtant, je crois que certains utilisent des cartes 12V. Bizarre !
Et si tu alimentes ta carte relais en 5v ? ou en 9v via une pile par exemple ?


Dernière édition par xav71 le Jeu 1 Juin 2017 - 22:38, édité 1 fois
Revenir en haut Aller en bas
Aetios

avatar

Messages : 970
Département : 50

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Jeu 1 Juin 2017 - 22:15

et en changeant le jumper, ça fait quoi ?
Revenir en haut Aller en bas
https://www.facebook.com/TheFrenchclanclan/
xav71

avatar

Messages : 219
Département : 69

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Ven 2 Juin 2017 - 8:48

Un lien intéressant (pour moi en tout cas) sur l'alimentation des relais.
En alim externe du relais, pas besoin de relier les masses de l'alim externe avec celle de la KL, car lien via un optocoupleur (donc pas de lien électrique).
Désolé de ne pas pouvoir aider plus @Nnanard8, j'ai surement plus encore à apprendre que toi





[url=https://www.raspberrypi.org/forums/viewtopic.php?f=65&t=38028]https://www.raspberrypi.org/forums/viewtopic.php?f=65&t=38028[/url]
Revenir en haut Aller en bas
Aetios

avatar

Messages : 970
Département : 50

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Ven 2 Juin 2017 - 9:10

@xav71 : je pense que tu as trouvé Wink

donc concrètement @Nnanard8, ça veux dire qu'il faut que tu amènes ton 12V ("+" et masse) sur la partie à droite de ton relais (là où il y a le jumper à enlever) et sur les pins au centre, tu raccordes la masse et le + qui viennent de ta KL25Z.

ça prends tout son sens avec les tests que tu avais fais @Nnanard8 car effectivement le jumper permet une liaison entre l'alimentation de la commande et celles des relais :

- En alimentant le PIN VCC en 12V, tes relais avait assez de tension pour se fermer, mais quand tu arrivais avec un tension inférieure à 12V sur le Pin de commande, le relais voyait un état "bas" et donc se fermait
- En alimentant le PIN VCC en 5V, tes relais ne pouvaient pas se fermer car la tension était trop basse, par contre tu voyais une réaction sur les leds de contrôle.

t'as plus qu'à faire des tests et à nous redire Wink


Dernière édition par Aetios le Ven 2 Juin 2017 - 9:16, édité 1 fois
Revenir en haut Aller en bas
https://www.facebook.com/TheFrenchclanclan/
Nnanard8

avatar

Messages : 87
Département : 14

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Ven 2 Juin 2017 - 9:12

Yes ! Merci je test ca cet aprem. Merci encore de me prêter vos neurones.
Revenir en haut Aller en bas
Aetios

avatar

Messages : 970
Département : 50

MessageSujet: Re: [WIP 75%] Pincab nnanard8   Ven 2 Juin 2017 - 9:18

@Nnanard8 : j'ai édité mon message en y ajoutant mon diagnostic de tes test précédents, on touche au but Wink
Revenir en haut Aller en bas
https://www.facebook.com/TheFrenchclanclan/
 
[WIP 75%] Pincab nnanard8
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 2 sur 3Aller à la page : Précédent  1, 2, 3  Suivant

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
 :: Pincab :: Pincab des membres-
Sauter vers: