AccueilAccueil  MumbleMumble  WIPs Team PP  RechercherRechercher  MembresMembres  S'enregistrerS'enregistrer  ConnexionConnexion  Dons  








Partagez
 

 [RÉSOLU] Problème installation STM32

Aller en bas 
AuteurMessage
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyDim 21 Aoû 2016 - 9:47

bonjour

j'ai suivi le tuto DMD RGB pour essayé de mettre de la couleur sur mon spiderman stern 

j' ai assemblé tout les éléments  et, sur mon pc après avoir mis le firmware dans la carte stm32 j'ai bien l' affichage " pin2dmd virtual pinball" quand je suis branché en usb.

quand j' alimente en 5v le montage et que je branche la nappe video du flipper sur la carte stm32 , flipper allumé rien ne se passe .
quand j' alimente en 5v via un tranfo , j' ai rien qui s' affiche .

quand je garde branché le montage via usb sur mon pc  et que je connecte la nappe video du flipper sur la carte stm , j' ai bien l'affichage du flip en couleur pendant 1 minute , ensuite j' ai un message comme quoi il me manque la clé ?

peux tu me détailler ton montage stp , faut il des info sur une carte sd ? sur ma sd j' ai juste la config qui precise que je vaux passé sur du sam stern 

quelqu'un a déjà monté ceci sur un stern ?
[RÉSOLU] Problème installation STM32 Img_2011


a+
Revenir en haut Aller en bas
nikonesca

nikonesca

Messages : 734
Département : 31

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyDim 21 Aoû 2016 - 11:10

En fait il te faut juste dupliquer ton fichier key envoyé par Lucky01 et le renommer en pin2dmd.key puis tu colle ce fichier dans ta carte SD et normalement ça devrait fonctionner !


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:46, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
http://toulousemultiball.org
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 10:07

hello
merci pour ton aide

voila j' ai ma clé  (merci a "lucky1") copié sur ma sd

voici ce que j' ai sur la sd :

PIN2DMD.DAT
pin2dmd.key
PIN2DMD.PAL

branché en usb sur le pc --> la dalle rgb s' allume comme la photo ci dessus
branché en usb sur le pc + nappe vidéo du flipper spiderman --> affichage du flip sur la dalle rgb!
alimenté seulement en 5v avec une alim --> rien sur la dalle ! normal ? la led com a gauche de la prise mini usb clignote .
alimenté en 5v + nappe vidéo du flip --> rien !?

une idée sur le problème ?
a+


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:49, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
nikonesca

nikonesca

Messages : 734
Département : 31

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 10:12

Normalement tu as sur la carte shield un cluster à déplacer selon le type d'alimentation usb ou 5v en direct.
Je pense que cela viens de là !
A plus
Revenir en haut Aller en bas
http://toulousemultiball.org
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:12

salut

le jumper sur la carte de rappel box semble en bonne position , si je le déplace je n'ai plus rien qui s' allume ( led) 
y a t il un jumper sur la stm32 a changé?
a+


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:49, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
nikonesca

nikonesca

Messages : 734
Département : 31

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:15

Normalement non pas de modification à faire sur la STM32. Questions peut-être bête mais à tu vérifié tes tensions d'arrivé ? As-tu bien respecté la polarité ? As-tu les voyants de la carte shield qui s'allume une fois sous tension et sans l'usb de la STM32 ?


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:50, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
http://toulousemultiball.org
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:32

voila ce que j' ai comme led d ' allumé avec juste une alim 5v ( vérifié)
la led sous le mini usb clignote!
[RÉSOLU] Problème installation STM32 Img_2012


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:50, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
leevuth

leevuth

Messages : 3699
Département : Yvelines

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:36

Salut,

J'ai mon troisième kit qui est exactement comme le tien. Normalement j'ai juste branché la STM32 au pc et ça marche sans souci. Pas besoin d'ajouter une alimentation de 5v
Revenir en haut Aller en bas
17Al3x17

17Al3x17

Messages : 1747
Département : 72 et 17

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:39

Oui mais lui il veux le mettre sur un vrai flipper Wink

C'est quoi l'autre entré +5v en haut à droite ? 
Le jumper à gauche des entrées ?


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:50, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
nikonesca

nikonesca

Messages : 734
Département : 31

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:41

@nikonesca a écrit:
Au démarrage de la stm32 et tout connecté dans le flipper, vois tu au moins le logo pin2dmd sur tes afficheurs led ?
tu peu la rebooter en appuyant sur le bouton noir en face du bleu ? normalement tu dois au moins voir le logo apparaître même rapidement…
Si tu n'as rien du tout re-vérifie tes différents connecteur ! Si tu as le logo mais après écran noir alors que le flipper est allumé et branché, c'est sans doute qu'il y'a un défaut sur le shield (j'ai eu ce cas la dernière fois un shield sur deux qui a des défaut coté connecteur DMD)


Edit :
@17Al3x17 a écrit:
@leevuth a écrit:
Salut,

J'ai mon troisième kit qui est exactement comme le tien. Normalement j'ai juste branché la STM32 au pc et ça marche sans souci. Pas besoin d'ajouter une alimentation de 5v
Oui mais lui il veux le mettre sur un vrai flipper Wink

C'est quoi l'autre entré +5v en haut à droite ? 
Le jumper à gauche des entrées ?
Bonne idée ! essaye en alimentant sur les bornier plutôt que par le jack !
mais pour moi tu as de la tension donc le pbest plus loin !


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:37, édité 2 fois (Raison : Messages successifs fusionnés ;))
Revenir en haut Aller en bas
http://toulousemultiball.org
leevuth

leevuth

Messages : 3699
Département : Yvelines

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:42

Ah zut j'ai pas lu le début  [RÉSOLU] Problème installation STM32 3253257302.

Sinon il faut juste brancher via le hub78 puis l'alimenter via l'usb

As tu aussi, sélectionner la marque de ton flipper via le logiciel Pin2dmd.exe ?


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:51, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:50

@leevuth a écrit:
Salut,

J'ai mon troisième kit qui est exactement comme le tien. Normalement j'ai juste branché la STM32 au pc et ça marche sans souci. Pas besoin d'ajouter une alimentation de 5v
 je comprends 

cela fonctionne parfaitement connecté en usb sur mon pc
mais je souhaite mettre le dmd rgb dans mon flipper spiderman de stern , donc sans connexion pc , juste avec une alim de 5v et la nappe video du flipper .
cela fonctionne pour le moment dans mon flip qu' avec le pc de connecté.
a+
Revenir en haut Aller en bas
leevuth

leevuth

Messages : 3699
Département : Yvelines

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:53

Ok, pardon, je n'avais pas compris.
Donc tu as alimenté la carte en 5v et branché à ton flipper via la nappe hub78. 
As tu lancé le pin2dmd.exe pour sélectionner ton flipper Stern ? Car par défaut la carte est configuré sur virtual pinball.
Revenir en haut Aller en bas
nikonesca

nikonesca

Messages : 734
Département : 31

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:54

@metwurcht a écrit:

cela fonctionne pour le moment dans mon flip qu' avec le pc de connecté.
a+
 Si je comprend bien tu as les animations du vrai flipper à travers tes nouveaux afficheurs mais que quand tu as le PC de branché ?
Revenir en haut Aller en bas
http://toulousemultiball.org
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 11:58

@nikonesca a écrit:
Au démarrage de la stm32 et tout connecté dans le flipper, vois tu au moins le logo pin2dmd sur tes afficheurs led ?
tu peu la rebooter en appuyant sur le bouton noir en face du bleu ? normalement tu dois au moins voir le logo apparaître même rapidement…
Si tu n'as rien du tout re-vérifie tes différents connecteur ! Si tu as le logo mais après écran noir alors que le flipper est allumé et branché, c'est sans doute qu'il y'a un défaut sur le shield (j'ai eu ce cas la dernière fois un shield sur deux qui a des défaut coté connecteur DMD)
non pas de logo !

quand je reboot , -->rien


defaut sur le connecteur DMD ? celui qui vas au rgb ou celui a connecté sur le vrai flipper .

ça fonctionne avec un pc de branché , donc pour moi les connecteur sont bon


Edit :
@nikonesca a écrit:
@metwurcht a écrit:

cela fonctionne pour le moment dans mon flip qu' avec le pc de connecté.
a+
 Si je comprend bien tu as les animations du vrai flipper à travers tes nouveaux afficheurs mais que quand tu as le PC de branché ?
oui


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:38, édité 1 fois (Raison : Messages successifs fusionnés)
Revenir en haut Aller en bas
leevuth

leevuth

Messages : 3699
Département : Yvelines

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 12:04

Bon, je viens de relire le début de ton problème.

En fait ta connexion est bonne, il te manque juste la carte microsd avec la clé (que tu renommes en pid2dmd.key et que tu copies sur la carte).
Revenir en haut Aller en bas
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 12:08

tu as du rater un post car j' ai bien la clé ( fourni par lucky1 )sur la sd 
a+


Dernière édition par shadow_shd le Lun 22 Aoû 2016 - 14:51, édité 1 fois (Raison : Suppression citation message précédent)
Revenir en haut Aller en bas
17Al3x17

17Al3x17

Messages : 1747
Département : 72 et 17

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 12:14

est ce que tu passes par l'éditeur ? Essaye de changer la palette de couleur, le mode et la clé via l'éditeur pour voir
Revenir en haut Aller en bas
nikonesca

nikonesca

Messages : 734
Département : 31

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 12:20

Sinon tente en branchant un autre PC ou un bloc alim usb de téléphone ! Si ca fonctionne aussi ce n'est pas obligatoirement la SD ou la key !
Revenir en haut Aller en bas
http://toulousemultiball.org
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 12:56

salut et merci a vous pour vos conseils

j' ai résolu le problème en mettant a jour le firmware de la st32

[RÉSOLU] Problème installation STM32 Captur11


a+
Revenir en haut Aller en bas
leevuth

leevuth

Messages : 3699
Département : Yvelines

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 12:58

A la tienne
Revenir en haut Aller en bas
nikonesca

nikonesca

Messages : 734
Département : 31

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 14:11

Cool !!!!!! Alors bon flip en colorama !!!!!
Revenir en haut Aller en bas
http://toulousemultiball.org
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: [RESOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 14:35

maintenant il va falloir que je trouve le patch pour coloriser la rom du spiderman et la rom de l' acdc LE.
et comment gerer le fichier side channel de pinball browser .a+
Revenir en haut Aller en bas
Shadow_SHD
Admin
Shadow_SHD

Messages : 15129
Département : 33

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 14:54

Metwurcht : parce que le tuto du DMD RGB arrive à sa limite de nombre de messages avant division automatique, j'ai créé un nouveau sujet pour ton problème Wink

De plus, j'ai supprimé les citations de citations de citations (etc... [RÉSOLU] Problème installation STM32 773715342 ) de messages précédents qui alourdissent la lecture [RÉSOLU] Problème installation STM32 3746298195 [RÉSOLU] Problème installation STM32 722859262

J'ai également fusionné les messages postés par un même membre à quelques minutes d'intervalle lol!

++
Revenir en haut Aller en bas
metwurcht

metwurcht

Messages : 16
Département : 70

[RÉSOLU] Problème installation STM32 Empty
MessageSujet: Re: [RÉSOLU] Problème installation STM32   [RÉSOLU] Problème installation STM32 EmptyLun 22 Aoû 2016 - 15:10

merci a toi , shadow_shd pour ton travail !
Revenir en haut Aller en bas
 
[RÉSOLU] Problème installation STM32
Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Pincab Passion :: Pincab :: Pin2DMD-
Sauter vers: