Pincab Passion
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.



 
AccueilAccueil  MumbleMumble  WIPs Team PP  RechercherRechercher  S'enregistrerS'enregistrer  ConnexionConnexion  Dons  








 

 [RÉSOLU] Contacteurs qui se déclenchent bizarrement

Aller en bas 
2 participants
AuteurMessage
paf_prod




Messages : 239
Département : 78

[RÉSOLU] Contacteurs qui se déclenchent bizarrement Empty
MessageSujet: [RÉSOLU] Contacteurs qui se déclenchent bizarrement   [RÉSOLU] Contacteurs qui se déclenchent bizarrement EmptyMar 5 Mai 2020 - 17:07

Bonjour à tous,

Je vais essayer de vous exposer mon problème que je n'arrive absolument pas à comprendre. (et qui n'est pas forcement facile à expliquer !)

Pendant le confinement, je me suis lancé dans la construction d'un 2eme Pincab (faut bien s'occuper  [RÉSOLU] Contacteurs qui se déclenchent bizarrement 722859262).
Tout est ok et fonctionnel, tout ?... Ben non, y'a un truc qui déconne bien sûr.

Il s'agit des contacteurs siermmens, pour le moment je n'en ait que 2 (il faut que j'en trouve 8 autres à acheter), je les ait donc installés au niveau de mes batteurs et dans la configuration du DOF je leur ait attribué 2 sorties de ma KL25Z comme suit :
- Sortie 13 (non pwm) à Flipper Right
- Sortie 14 (non pwm) à Flipper Left

J'ai bien sauvegardé ma configuration et enregistré les fichiers décompréssés du Directoutout.zip dans C:\DIRECTOUTPUT\Config

Je lance PinscapeTool et je vérifie toutes mes sorties une à une, elles fonctionnent PARFAITEMENT.

Là où ça se gâte, c'est lorsque je lance une table sous VPX ou 9, peut importe que ce soit STERN, WILLIAMS, BALLY, GOTTLIEB ou autre, la jeu démarre.

Les lumières des boutons, de la WS2811 et des 5 flashers RGB sont au top, les boutons réagissent bien, par contre, quand j'appui sur les boutons des flips droit et gauche, ben les contacteurs ne se déclenchent qu'environ 1 fois sur 10 !
et plus bizarre encore, alors que je n'ai déclaré aucune sortie pour les 2 slingshoots, il fonctionnent à merveille sur les contacteurs attribués au flip !  pas mal

Le contacteur droit fonctionne également parfaitement pour l'ejecteur et le lance bille.
A n'y rien comprendre...

Est-ce que quelqu'un à déjà eu ce soucis de fonctionnement et comment y remédier ? Là je sèche complètement.

Un grand merci d'avance pour vos soutiens et vos lumières  Idea


Dernière édition par paf_prod le Mer 6 Mai 2020 - 19:01, édité 1 fois
Revenir en haut Aller en bas
paf_prod




Messages : 239
Département : 78

[RÉSOLU] Contacteurs qui se déclenchent bizarrement Empty
MessageSujet: [EN COURS] Contacteurs qui se déclenchent bizarrement   [RÉSOLU] Contacteurs qui se déclenchent bizarrement EmptyMar 5 Mai 2020 - 18:40

J'ai une seconde KL25Z, je vais essayer de la remplacer pour voir s'il n'y aurait pas un problème à son niveau.

[EDIT]
KL25Z remplacée par une neuve et.....aucun changement, ça ne vient donc pas de la carte. Un coup d'épée dans l'eau.
Revenir en haut Aller en bas
paf_prod




Messages : 239
Département : 78

[RÉSOLU] Contacteurs qui se déclenchent bizarrement Empty
MessageSujet: Re: [RÉSOLU] Contacteurs qui se déclenchent bizarrement   [RÉSOLU] Contacteurs qui se déclenchent bizarrement EmptyMer 6 Mai 2020 - 19:02

Effectivement je me sert du bornier coté sorti des MOSFET (donc coté ou je branche mes Toys) pour y raccorder le + et le gnd du 24 volts ou 12 volts selon la carte.

ça me permet de pouvoir utiliser le + directement sur les sortoes Toys  CH1, CH2, CH3 et CH4

Je peux essayer de ne mettre QUE du 12 volts sur les POWER des cartes Mosfets et raccorder tous mes toys 24v sur le + directement en sortie de mon réhausseur de tensions.

Mais tu as raisons, je ne vois pas en quoi cela pourrait corriger le problème si ça fonctionne sous PINSCAPE CONFIG TOOL, tout au mieux, je soulagerais mes MOSFETs s'il ne faut pas dépasser 20 volts.

[EDIT 1]
Modifs effectuées : l'ensemble de mes 7 cartes MOFSET*4 sont passées en 12 volts (connecteur marqué POWER). J'ai relié le + de mes 2 relais directement à la sortie + du 24 volt de mon réhausseur de tension et la masse est restée connectée sur les sorties CH1 et CH2.

==> Aucun changement.
J'aime pas ne pas comprendre, y'a un truc, forcément, mais où et quoi ?...  Evil or Very Mad

[EDIT 2]
J'ai peut être une autre piste : sur mon premier Pincab, je n'avais qu'une seule KL25Z et un WS2811, et ça fonctionne très bien.
Sur celui que je suis en train de faire et qui déconne, j'ai en plus une carte d'extension "MASTER OF MOSFETS" de chez "Arnoz".
Afin de la déclarer, il à fallu que je modifie ma configuration DOF comme suit :
Suppression de la "LEDWIZ 1" pour la remplacer par une "Pinscape 1"
Par contre, au niveau de la configuration du Pinscape Config Tool, c'est toujours une Ledwiz qui est affiché, ne dois-je pas également modifier à ce niveau là ??? Par exemple, j'ai toujours "Ledwiz Unit 1" dans USB identification, ne devrais-je pas changer par "Pinscape ID" ?

[EDIT 3]
Euréka !!! c'est bien ça, ça fonctionne du tonner maintenant !!  cheers

slocope aime ce message

Revenir en haut Aller en bas
slocope

slocope


Messages : 32
Département : 78

[RÉSOLU] Contacteurs qui se déclenchent bizarrement Empty
MessageSujet: Re: [RÉSOLU] Contacteurs qui se déclenchent bizarrement   [RÉSOLU] Contacteurs qui se déclenchent bizarrement EmptyMar 11 Jan 2022 - 11:49

Merci Paf_prod pour ton post

cela fait depuis le démarrage de mon premier Pincab que je ne comprenais pas pourquoi je n'avais pas les contacteurs associés aux flippers, qui se declenchait de la même façon sur toutes les tables,

Ce qui m'a enduit d'erreur est que sur ACDC les flippers et les contacteurs etait bien associés, alors que sur une autre table comme Gun & Roses par exemple le Flipper gauche declenchait le contacteur du slingshot, et le flipper droit rien du tout,

J'ai perdu du temps dans mes recherches, car je pensais que le pb venait d'un pb d'adressage dans DOF au niveau des tables. Ceci à TORT

La solution etait une erreur de config dans pinscape Tool : dans USB identification j'avais "Ledwitz Unit1", j'ai modifié avec "Pinscape ID" et miantenant tout semble fonctionner correctement,

Merci tu m'as retiré une grosse épine sur ce post

paf_prod aime ce message

Revenir en haut Aller en bas
 
[RÉSOLU] Contacteurs qui se déclenchent bizarrement
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [RÉSOLU] Contacteurs 12v ou 24v ?
» [RÉSOLU] Aide Contacteurs
» [RESOLU]ou acheter 10 contacteurs Sirius
» [RÉSOLU] DOF contacteur sur les battants du flipper
» [RÉSOLU]Problème avec contacteurs

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Pincab Passion :: Émulateurs, Frontends & Tables pour Pincab :: Émulateurs :: DOF -Direct Output Framework :: DOF - Installation et résolution des problèmes-
Sauter vers: